Dreamdata - Data modelling not running – Incident details
All systems operational
Data modelling not running
Resolved
Degraded performance
Started about 2 months agoLasted 2 days
Affected
Data Model
Degraded performance from 12:00 PM to 12:30 PM
Updates
Resolved
Resolved
The under-provisioned database has been fixed.
Due to the TTL or Table Expiration being set to 1 day on the Data Warehouse tables in BigQuery, customer tables were deleted around Sunday. This TTL has now been increased to 7 days to mitigate future issues, ensuring that tables do not get deleted if pipelines fail to run for any reason.
The Dreamdata App and Data Warehouse run as usual, aside from the data not being updated.
As soon as the pipeline was fixed, all data was updated retrospectively.
Sorry for any inconvenience it might have caused.
Investigating
Investigating
Due to a database being under-provisioned, data modeling pipelines are down. Resulting in data not being updated.
The Application, Data Warehouse etc. are functionally with stale data.